VPN zwischen Linksys WRVS4400N und Netgear FVS338

Erstellt: 01.04.2008, 16:20 | Editiert: 26.10.2018, 06:27 | 2.788 mal angesehen | Eintrag drucken | Kategorie(n): Internet

Nach einigem Basteln steht der VPN zwischen meinem neuen Linksys und dem Netgear in der Arbeit.

Mit der Firmware 1.00.16 auf dem Linksys-Router war es unmöglich, erst die 1.01.03 hat es möglich gemacht. Auf dem Netgear läuft die V1.6.48 als aktive "primary" Firmware und die V2.0.0-141 inaktiv als "secondary".

Auch nach dem Updaten des WRVS4400N auf 1.01.03 war es zunächst nicht möglich, einen Tunnel aufzubauen, das hat ziemlich viele Nerven und Zeit gekostet… Trick: Erst nach Löschen der Tunnel-Definition auf dem Netgear und neuem Anlegen (IKE Policy + "Auto" VPN-Policy) ging es.

Netzwerk

Das Subnetz auf der Firmenseite ist 192.168.B.0/24, der Netgear dort hat eine statische IP.

Das Subnetz zu Hause ist 192.168.A.0/24, der Linksys hat eine dynamische IP und den DynDNS-Hostnamen A.dyndns.org.

Netgear, IKE-Policy

netgear_ike.png

Netgear, VPN-Policy

netgear_vpn.png

Linksys Konfiguration

linksys.png

hier ist "aggesssive mode" ausgewählt, fällt mir gerade auf. Obwohl im Netgear "main mode" steht, funktioniert es so.

Routing

In der Arbeit gibt es für Maschinen noch das 10er-Subnetz, als Router dort fungiert eine Linux-Box mit der IP 192.168.B.241. Um auch das 10er-Netz zu erreichen wird auf dem Linksys folgende Route angelegt:

Destination IP Address: 10.0.0.0 
Subnet Mask: 255.0.0.0 
Gateway: 192.168.B.241

und obwohl diese Route nicht unter "Show routing table" auf dem Linksys-Router gelistet ist, funktioniert es.

Ähnliches

Seiten und Einträge, gefunden nach Tags.

Schreibe einen Kommentar

Captcha * Time limit is exhausted. Please reload CAPTCHA.